desfree_pct(5)desfree_pct(5)NAMEdesfree_pct - sets the lower bound before paging daemon starts stealing
pages, specified as a percentage of available physical memory
Must not be greater than (see lotsfree_pct(5)).
is a tunable parameter to set the lower bound before the paging daemon
start stealing pages. It is specified as a percentage of physical mem‐
ory available after boot.
must be a positive integer between 0 and 30 and must be equal to or
less than (see lotsfree_pct(5)). Trying to set higher than results in
The paging daemon in HP-UX acts on a "two hand" model. The daemon runs
at least once a second, with one part marking pages of virtual address
space as "unused". If the page is referenced before this "aging" hand
returns, it will be marked as "used" again. Another section of the
daemon, the "steal" hand follows the age hand (the distance between
them varies in a well bounded range) and processes pages which are
still marked "unused", since needed or frequently accessed pages would
have a high likelihood of being referenced in the gap between the
Exactly how the steal hand treats the pages still marked as "unused"
depends on the comparison of free system physical memory and three pag‐
ing parameters: and Between and is a periodically re-calculated and,
hence floating, threshold known as Thus and are the upper and lower
bounds between which moves.
is an expression of how much the system maintains, expressed in per‐
centage terms (percentage of physical memory available after boot).
· If is greater than the system's memory availability is in good
shape. The steal hand does nothing as a lot of memory is still
available on the system, so there is no need to "steal' a page that
might be needed soon.
· In the more common case, when is lower than (but higher than the
steal hand will begin to steal pages that have remained unreferenced
from when the age hand last marked them. "Stealing" a page refers
to the process of freeing the page from being allocated for a par‐
ticular virtual page and making it available for general allocation
again. If falls below but is still more than memory availability is
still in reasonable shape, but the paging daemon begins stealing
pages more aggressively, including putting lower priority processes
to sleep to free up their memory.
· When is less than free memory in the system is getting more criti‐
cal; the paging daemon begin deactivating low priority processes, in
other words, swapping out pages to the swap device.
Since the exact memory topography varies widely across supported plat‐
forms, the paging parameters and are tunable to allow for cases where
the default values are insufficient, or where the system administrator
requires more control over the actions of the paging daemon. In gen‐
eral, however, the automatic calculation performed by default should
suffice for most systems. is a system calculated value.
Who Is Expected to Change This Tunable?
Anyone with super-user privileges.
Restrictions on Changing
Changes to this tunable take effect immediately.
When Should the Value of This Tunable Be Raised?
This tunable should be raised on systems where system memory is criti‐
cal for short-term, high priority processes, but is being held by low-
priority, long running processes. For example, when one web server is
forking off per-connection threads while 50 RCS clients run in the
Increasing (and hence would raise the likelihood of the low-priority
processes being put to sleep, allowing the high-priority processes a
chance to acquire the pages that were previously allocated to the for‐
What are the Side Effects of Raising the Value?
As increases, more low priority processes might be forced to sleep.
Depending on what these processes are actually doing, this may not be
the right approach.
When Should the Value of This Tunable Be Lowered?
Raising too high can impair performance of lower priority processes as
In addition, raising and increases system overhead (it takes time to
swap a page to disk), and should be weighed carefully against the need
or desire to keep a large pool of physical memory unused.
Some free memory is essential, a moderate amount is probably good, a
lot of free memory just sitting idle is a waste. If the available
physical memory on the machine seems generous and heavy swapping is
occurring, lowering and/or will increase memory usage but decrease
What are the Side Effects of Lowering the Value?
More physical memory will be in use before processes are put to sleep
to try to reclaim their frames.
What Other Tunable Values Should Be Changed at the Same Time?
should be considered when modifying for reasons previously described
above. acts as a firm upper bound to so attempting to set above is
meaningless and will result in an error. See lotsfree_pct(5).
Starting with HP-UX 11i Version 2, HP recommends the use of to specify
the lower bound for the paging daemon.
Memory resource management infrastructure is busy.
Please try later.
Attempting to set
An invalid value is entered that is not an integer between
0 and 30, such as an negative number.
All HP-UX kernel tunable parameters are release specific. This parame‐
ter may be removed or have its meaning changed in future releases of
Installation of optional kernel software, from HP or other vendors, may
cause changes to tunable parameter values. After installation, some
tunable parameters may no longer be at the default or recommended val‐
ues. For information about the effects of installation on tunable val‐
ues, consult the documentation for the kernel software being installed.
For information about optional kernel software that was factory
installed on your system, see at
was developed by HP.
Tunable Kernel Parameters desfree_pct(5)