DEVFS.CONF(5) BSD File Formats Manual DEVFS.CONF(5)NAMEdevfs.conf — boot-time devfs configuration information
The devfs.conf file provides an easy way to set ownership and permis‐
sions, or create links for devices available at boot.
It does not work for devices plugged in and out after the system is up
and running, e.g. USB devices. See devfs.rules(5) for setting ownership
and permissions for all device nodes, and devd.conf(5) for actions to be
taken when devices are attached or detached.
Lines starting with a hash sign (‘#’) and empty lines are ignored. The
lines that specify devfs.conf rules consist of three parameters separated
action The action to take for the device. The action names are only
significant to the first unique character.
The name of the device created by devfs(5).
arg The argument of the action.
The actions currently supported are:
link This action creates a symbolic link named arg that points to
devname, the name of the device created by devfs(5).
own This action changes the ownership of devname. The arg parameter
must be in the form of an owner:group pair, in the same format
used by chown(8).
perm This action changes the permissions of devname. The arg parame‐
ter must be a mode as explained in chmod(1).
To create a /dev/cdrom link that points to the first SCSI(4) or
atapicam(4) CD-ROM, the following may be added to devfs.conf:
link cd0 cdrom
Similarly, to link /dev/cdrom to the first ATAPI CD-ROM device, the fol‐
lowing action may be used:
link acd0 cdrom
To set the owner of a device, the own action may be specified:
own cd0 root:cdrom
To set the permissions of a device, a perm action should be used:
perm cd0 0660
SEE ALSOchmod(1), devd.conf(5), devfs(5), devfs.rules(5), chown(8)AUTHORS
This manual page was written by Roland Smith ⟨email@example.com⟩.
BSD May 17, 2005 BSD