IXGB(4) BSD Kernel Interfaces Manual IXGB(4)NAME
ixgb — Intel(R) PRO/10GbE Ethernet driver for the FreeBSD operating sys‐
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The ixgb driver provides support for PCI Gigabit Ethernet adapters based
on the Intel 82597EX Ethernet controller chips. The driver supports
Transmit/Receive checksum offload and Jumbo Frames.
For questions related to hardware requirements, refer to the documenta‐
tion supplied with your Intel PRO/10GbE adapter. All hardware require‐
ments listed apply to use with FreeBSD.
Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con‐
figures the adapter to receive and transmit Jumbo Frames. The maximum
MTU size for Jumbo Frames is 16114.
This driver version supports VLANs. For information on enabling VLANs,
The ixgb driver supports the following cards:
· Intel PRO/10GbE LR Server Adapter
· Intel PRO/10GbE SR Server Adapter
ixgb%d: Unable to allocate bus resource: memory A fatal initialization
error has occurred.
ixgb%d: Unable to allocate bus resource: interrupt A fatal initializa‐
tion error has occurred.
ixgb%d: watchdog timeout -- resetting The device has stopped responding
to the network, or there is a problem with the network connection
For general information and support, go to the Intel support website at:
If an issue is identified with the released source code on the supported
kernel with a supported adapter, email the specific information related
to the issue to ⟨firstname.lastname@example.org⟩.
SEE ALSOarp(4), em(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)HISTORY
The ixgb device driver first appeared in FreeBSD 4.11 and FreeBSD 5.3.
The ixgb driver was written by Intel Corporation
BSD August 18, 2006 BSD