ip6(8) BSD System Manager's Manual ip6(8)NAMEip6 — Enable or disable IPv6 on active interfaces
SYNOPSISip6 [-ax] [-ud -interface]
DESCRIPTIONip6 can be used to start up or shut down IPv6 on active interfaces. When
IPv6 is enabled on an interface the protocol is attached to the inter‐
face, at which point the default settings in the kernel allow it to
acquire a link-local address and accept router advertisements. Disabling
detaches the protocol from the interface.
Possible options are:
-a Start IPv6 on all interfaces.
-x Stop IPv6 on all interfaces.
Start IPv6 on interface.
Stop IPv6 on interface.
You need support for IPv6 in your kernel. This is provided beginning with
Darwin Kernel Version 6.0.
The default IPv6 configuration for an interface assigns a link-local
address to it and sets the interface to receive router advertisements.
No further configuration is necessary for basic functionality. However,
various settings can be modified by using sysctl. Pp
SEE ALSOstf(4), IPv6 Documentation at
http://www.netbsd.org/Documentation/network/ipv6/, RFC 3068.
BSD May 23, 2002 BSD