IXGBE(4) BSD Kernel Interfaces Manual IXGBE(4)NAMEixgbe — Intel(R) 10Gb Ethernet driver for the FreeBSD operating system
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The ixgbe driver provides support for PCI 10Gb Ethernet adapters based on
the Intel 82598EB Intel(R) Network Connections. The driver supports
Jumbo Frames, MSIX, TSO, and RSS.
For questions related to hardware requirements, refer to the documenta‐
tion supplied with your Intel 10GbE adapter. All hardware requirements
listed apply to use with FreeBSD.
Support for Jumbo Frames is provided via the interface MTU setting.
Selecting an MTU larger than 1500 bytes with the ifconfig(8) utility con‐
figures the adapter to receive and transmit Jumbo Frames. The maximum
MTU size for Jumbo Frames is 16114.
This driver version supports VLANs. For information on enabling VLANs,
The ixgbe driver supports the following cards:
· Intel(R) 10 Gigabit XF SR/AF Dual Port Server Adapter
· Intel(R) 10 Gigabit XF SR/LR Server Adapter
· Intel(R) 82598EB 10 Gigabit AF Network Connection
· Intel(R) 82598EB 10 Gigabit AT CX4 Network Connection
ixgbe%d: Unable to allocate bus resource: memory A fatal initialization
error has occurred.
ixgbe%d: Unable to allocate bus resource: interrupt A fatal initializa‐
tion error has occurred.
ixgbe%d: watchdog timeout -- resetting The device has stopped responding
to the network, or there is a problem with the network connection
For general information and support, go to the Intel support website at:
If an issue is identified with the released source code on the supported
kernel with a supported adapter, email the specific information related
to the issue to ⟨email@example.com⟩.
SEE ALSOarp(4), netintro(4), ng_ether(4), polling(4), vlan(4), ifconfig(8)HISTORY
The ixgbe device driver first appeared in FreeBSD 7.0.
The ixgbe driver was written by Intel Corporation
BSD June 11, 2008 BSD