keyserv(1M)keyserv(1M)NAMEkeyserv - server for storing private encryption keys
[ ] [ ] [ ]
is a daemon that is used for storing the private encryption keys of
each user logged into the system. These encryption keys are used for
accessing secure network services such as secure NFS.
Normally, root's key is read from the file when the daemon is started.
This is useful during power-fail reboots when no one is around to type
will not start up if the system does not have a secure RPC domain con‐
figured. The domain name can be set up by using the command. Invoking
the command without arguments will display whether the user has a
domain set up.
The file contains the following default parameter settings.
Specifies whether default keys for are used.
The default value is
is equivalent to the command-line option.
Disable the use of default keys for
Enable the use of default keys for
This is the default behavior.
Run in debugging mode and log all requests to
Root's secret key is not read from
Instead, prompts the user for the password to decrypt root's key
stored in the database and then stores the decrypted key in for
This option is useful if the file ever gets out-of-date or cor‐
HP-UX 11i Version 2 is the last HP-UX release on which NIS+ is sup‐
ported. LDAP is the recommended replacement for NIS+. HP fully sup‐
ports the industry standard naming services based on LDAP.
was developed by Sun Microsystems, Inc.
Contains root's key.
Contains default settings.
You can use command-line options to override these settings.
SEE ALSOkeylogin(1), keylogout(1), publickey(4).