MFI(4) BSD Kernel Interfaces Manual MFI(4)NAMEmfi — LSI MegaRAID SAS driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
This driver is for LSI's next generation PCI Express SAS RAID con‐
trollers. Access to RAID arrays (logical disks) from this driver is pro‐
vided via /dev/mfid? device nodes. A simple management interface is also
provided on a per-controller basis via the /dev/mfi? device node.
The mfi name is derived from the phrase "MegaRAID Firmware Interface",
which is substantially different than the old "MegaRAID" interface and
thus requires a new driver. Older SCSI and SATA MegaRAID cards are sup‐
ported by amr(4) and will not work with this driver.
Two sysctls are provided to tune the mfi driver's behavior when a request
is made to remove a mounted volume. By default the driver will disallow
any requests to remove a mounted volume. If the sysctl
dev.mfi.%d.delete_busy_volumes is set to 1, then the driver will allow
mounted volumes to be removed.
The mfi driver supports the following hardware:
· LSI MegaRAID SAS 1078
· LSI MegaRAID SAS 8408E
· LSI MegaRAID SAS 8480E
· LSI MegaRAID SAS 9260
· Dell PERC5
· Dell PERC6
· IBM ServeRAID M5015 SAS/SATA
· IBM ServeRAID-MR10i
· Intel RAID Controller SROMBSAS18E
/dev/mfid? array/logical disk interface
/dev/mfi? management interface
mfid%d: Unable to delete busy device An attempt was made to remove a
SEE ALSOamr(4), pci(4), mfiutil(8)HISTORY
The mfi driver first appeared in FreeBSD 6.1.
The mfi driver and this manual page were written by Scott Long
The driver does not support big-endian architectures at this time.
BSD May 12, 2010 BSD