PNOZZ(4) OpenBSD Programmer's Manual (SPARC) PNOZZ(4)NAMEpnozz - Weitek Power9100 accelerated frame buffer
pnozz0 at sbus?
wsdisplay* at pnozz?
The pnozz is a color frame buffer with graphics acceleration, embedded in
the Tadpole SPARCbook 3GS, 3GX, 3TX and 3XP laptops. It is based on the
Weitek Power9100 video processor and an IBM RGB525 RAMDAC.
The pnozz driver interfaces the frame buffer with the wscons(4) console
framework. It does not provide direct device driver entry points but
makes its functions available via the internal wsdisplay(4) interface.
If the tctrl(4) device is also configured, the pnozz will be powered down
when the lid of the laptop is closed or the screen is blanked.
On machines with an 800 pixel wide display, the pnozz driver supports
hardware acceleration to erase the screen and scroll text.
If the tctrl(4) device is also configured, the external video output will
be enabled when an external display is connected, even if the laptop lid
SEE ALSOintro(4), sbus(4), wscons(4), wsdisplay(4)BUGS
It is not possible yet to change display resolution or color depth.
Acceleration code does not work correctly on 640 pixel wide displays,
such as on model 3XP, and is therefore disabled in this case.
OpenBSD 4.9 March 31, 2008 OpenBSD 4.9