SND_SBC(4) BSD Kernel Interfaces Manual SND_SBC(4)NAME
snd_sbc, snd_sb16, snd_sb8 — Creative Sound Blaster ISA and compatible
bridge device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following lines in loader.conf(5):
Non-PnP cards require the following lines in device.hints(5):
The snd_sbc bridge driver allows the generic audio driver sound(4) to
attach to Creative Sound Blaster ISA (mostly SB16 or SB8, known as Sound‐
Blaster Pro) compatible audio cards.
The value of flags specifies the secondary DMA channel. If the secondary
DMA channel is C, set the flags to (C | 0x10). For a sound card without
the secondary DMA channel, the flags should be set to zero.
The snd_sbc driver supports the following sound cards:
· Avance Asound 110
· Avance Logic ALS100+
· Avance Logic ALS120
· Creative SB16
· Creative SB32
· Creative AWE64
· Creative AWE64 Gold
· Creative ViBRA16C
· Creative ViBRA16X
· ESS ES1681
· ESS ES1688
· ESS ES1868
· ESS ES1869
· ESS ES1878
· ESS ES1879
· ESS ES1888
DIAGNOSTICSsb_dspwr(XX) timed out. A command to the DSP has timed out. Check the
I/O port configuration.
bad irq XX (5/7/9/10 valid) The IRQ given to the driver is not valid.
The snd_sbc device driver first appeared in FreeBSD 4.0.
Seigo Tanimura ⟨firstname.lastname@example.org⟩
BSD February 17, 2007 BSD