DEVICE_DETACH(9) BSD Kernel Developer's Manual DEVICE_DETACH(9)NAMEDEVICE_DETACH — detach a device
Detach a device. This can be called if the user is replacing the driver
software or if a device is about to be physically removed from the system
(e.g. for pccard(4) devices).
The method should deallocate any system resources allocated during the
DEVICE_ATTACH(9) method and reset the hardware to a sane state (i.e.,
disable interrupts etc.)
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSOpccard(4), device(9), DEVICE_ATTACH(9), DEVICE_IDENTIFY(9),
This manual page was written by Doug Rabson.
BSD June 16, 1998 BSD