DEVICE_ATTACH(9) BSD Kernel Developer's Manual DEVICE_ATTACH(9)NAMEDEVICE_ATTACH — attach a device
Attach a device to the system after the DEVICE_PROBE() method has been
called and has indicated that the device exists. The DEVICE_ATTACH()
method should initialize the hardware and allocate other system resources
(such as devfs(5) entries).
Devices which implement busses should use this method to probe for the
existence of devices attached to the bus and add them as children. If
this is combined with the use of bus_generic_attach(9) the child devices
will be automatically probed and attached.
Zero is returned on success, otherwise an appropriate error is returned.
SEE ALSOdevfs(5), device(9), DEVICE_DETACH(9), DEVICE_IDENTIFY(9),
This manual page was written by Doug Rabson ⟨dfr@FreeBSD.org⟩.
BSD January 6, 2005 BSD