AXE(4) OpenBSD Programmer's Manual AXE(4)NAMEaxe - ASIX Electronics AX88172/AX88178/AX88772 10/100/Gigabit USB
axe* at uhub?
rlphy* at mii?
eephy* at mii?
The axe driver provides support for USB Ethernet adapters based on the
ASIX Electronics AX88172, AX88178, and AX88772 USB 2.0 chipsets,
including the following:
Apple USB Ethernet Adapter A1277
Billionton Systems USB2AR
Corega FEther USB2-TX
Good Way GWUSB2E
Intellinet USB 2.0 to Ethernet (rev A)
Level One USB-0200
Nintendo Wii USB Lan Ethernet Adapter RVL-015
OQO model 01+ Ethernet
SnapPort USB 2.0 LAN Adapter
ST Lab USB 2.0 Fast Ethernet
System TALKS SGC-X2UL
The AX88172, AX88178, and AX88772 are USB 2.0 devices designed to work
with either Ethernet or HomePNA transceivers. The AX8172 and AX88772
contain 10/100 Ethernet MACs with MII interfaces. The AX8178 contains a
10/100/1000 Gigabit Ethernet MAC with a GMII/MII interface. All adapters
will operate with either USB 1.x or USB 2.0 controllers, however
performance with 1.x controllers will be limited since the USB 1.x
standard specifies a maximum transfer speed of 12Mbps. Users with USB
1.x controllers should therefore not expect to actually achieve 100Mbps
speeds with these devices.
A 64-bit multicast hash table is supported, single perfect filter entry
for the station address, all-multicast mode, and promiscuous mode.
Packets are received and transmitted over separate USB bulk transfer
The axe driver supports the following media types:
autoselect Enable autoselection of the media type and options (this is
the default). The user can manually override the
autoselected mode by adding media options to the appropriate
10baseT Set 10Mbps operation.
100baseTX Set 100Mbps (Fast Ethernet) operation.
1000baseT Set 1000Mbps (Gigabit Ethernet) operation (AX88178 only).
The axe driver supports the following media options:
full-duplex Force full-duplex operation.
half-duplex Force half-duplex operation.
The interface will operate in half-duplex mode if no media option is
For more information on configuring this device, see ifconfig(8).
axe%d: watchdog timeout A packet was queued for transmission and a
transmit command was issued, however the device failed to acknowledge the
transmission before a timeout expired.
axe%d: no memory for rx list The driver failed to allocate an mbuf for
the receiver ring.
SEE ALSOarp(4), eephy(4), ifmedia(4), intro(4), netintro(4), rlphy(4), usb(4),
ASIX AX88172 data sheet, http://www.asix.com.tw.
The axe device driver first appeared in OpenBSD 3.6.
The axe driver was written by Bill Paul <email@example.com> and ported
to OpenBSD by Greg Taleck <firstname.lastname@example.org>.
OpenBSD 4.9 September 19, 2010 OpenBSD 4.9