BOOT_ALPHA(8) OpenBSD System Manager's Manual (Alpha) BOOT_ALPHA(8)NAMEboot_alpha - Alpha system bootstrapping procedures
When powered on, the SRM firmware will proceed to its initialization, and
will boot an operating system if the auto_action variable is set to
``boot'' or ``restart'', or will wait for interactive commands if set to
After a panic, or if the system is rebooted via reboot(8) or shutdown(8),
the SRM console will only restart the system if the auto_action variable
is set to ``boot''.
Boot process options
The SRM console will attempt to boot a kernel named from the boot_file
environment variable, on the device listed in the bootdef_dev variable.
A list of the recognized SRM devices can be obtained with the command
show dev at the SRM prompt. If the boot_file variable is not set or
empty, /bsd will be used by default.
The kernel will be passed the options listed in the boot_osflags
variable. Option letters are case insensitive. The following option
letters are recognized:
a Boot the system multi-user. This is the default behaviour of
the kernel if no flags are specified.
b Enter the debugger, ddb(4), as soon as the kernel console has
c Enter the ``User Kernel Configuration'' mode upon startup
d Create a kernel crash dump immediately after the devices have
been configured. This option is only available on kernels
compiled with "option DEBUG".
h On the next system reboot, always halt the system, even if a
reboot is required.
n Prompt for the root filesystem device after the devices have
s Boot the system single-user.
Abnormal system termination
In case of system crashes, the kernel will usually enter the kernel
debugger, ddb(4), unless it is not present in the kernel, or it is
disabled via the ddb.panic sysctl. Upon leaving ddb, or if ddb was not
entered, the kernel will halt the system if it was still in device
configuration phase, or attempt a dump to the configured dump device, if
possible. The crash dump will then be recovered by savecore(8) during
the next multi-user boot cycle. It is also possible to force other
behaviours from ddb.
/bsd default system kernel
/bsd.rd standalone installation kernel, suitable for disaster
/usr/mdec/bootxx primary bootstrap for ``ffs'' file system
/usr/mdec/boot secondary bootstrap (usually also installed as /boot)
/usr/mdec/netboot network bootstrap
SEE ALSOddb(4), boot_config(8), halt(8), init(8), installboot(8), reboot(8),
savecore(8), setnetbootinfo(8), shutdown(8)
Alpha Architecture Reference Manual Third Edition, Digital Press, Alpha
Architecture Committee, 1998.
The device names used by OpenBSD/alpha and the SRM Console often have no
relation to each other.
OpenBSD 4.9 January 3, 2010 OpenBSD 4.9