BOOT_MAC68K(8) OpenBSD System Manager's Manual (Mac68k) BOOT_MAC68K(8)NAMEboot_mac68k - mac68k-specific system bootstrapping procedures
Power fail and crash recovery
Normally, the OpenBSD kernel on the mac68k architecture is booted from
the native operating system by means of an application program. When the
kernel takes over, it initializes itself and proceeds to boot the system.
An automatic consistency check of the file systems takes place, and
unless this fails, the system comes up to multi-user operations. The
proper way to shut the system down is with the shutdown(8) command.
If the system crashes, it will enter the kernel debugger, ddb(4), if it
is configured in the kernel. If the debugger is not present or has
exited, the system will attempt a dump to the configured dump device
(which will be automatically recovered with savecore(8) during the next
boot cycle). After the dump completes (successful or not), the system
will attempt a reboot.
On most mac68k machines with ``soft-power'' after the IIcx, the power
switch can be physically rotated and locked in the ``on'' position. The
native OS can be configured to automatically start the OpenBSD boot
program. Additionally, the OpenBSD boot program can be configured to
boot OpenBSD without intervention. When a system is so configured, it
can crash or lose power and reboot back to a fully multi-user state
without any intervention.
The boot application
The boot application runs in the native OS on the system. It has a
dialog where booting preferences may be changed and an option whereby
these options may be saved. The preferences are stored in the program
itself, not in a preferences folder, thus allowing two separate copies of
the program to be configured differently (e.g., to boot different bsd or
bsd.test, or to boot from two different drives).
One option that may be specified is a boot to single-user mode. This
stops the boot process very early on and allows system maintenance. If
one wishes to provide some security at this phase of the boot, remove the
``secure'' option from ttye0 in the ttys(5) file.
Another useful option that may be specified is the ``serial console''
option. This will allow a serial device (terminal or computer) to act as
a console for the system. This device must be configured to use 9600
baud, eight bits, no parity, and one stop bit (9600-8N1). Either the
printer port or the modem port (tty01 and tty00, respectively) may be
used for this.
It is sometimes useful to boot a kernel that resides in a folder in
native OS rather than from the usual location in the OpenBSD file system.
A radio button is supplied for this purpose. The kernel may be
compressed using gzip(1). Note that some programs will not run properly
if the kernel is not found as /bsd within the OpenBSD file system.
/bsd system kernel
/bsd.rd standalone installation kernel, suitable for disaster recovery
SEE ALSOddb(4), ttys(5), savecore(8), shutdown(8)OpenBSD 4.9 May 31, 2007 OpenBSD 4.9