EDSC(4) BSD Kernel Interfaces Manual EDSC(4)NAME
edsc — Ethernet discard network interface
The edsc interface is a software discard mechanism which may be used for
performance analysis and software testing. It imitates an Ethernet
device, which allows for its use in conjunction with such drivers as
if_bridge(4) and vlan(4).
As with other network interfaces, an edsc interface must have network
addresses assigned for each address family with which it is to be used.
These addresses may be set or changed with the SIOCSIFADDR ioctl(2) or
Each edsc interface is created at runtime using interface cloning. This
is most easily done with the ifconfig(8) create command or using the
cloned_interfaces variable in rc.conf(5).
SEE ALSOioctl(2), arp(4), if_bridge(4), inet(4), intro(4), vlan(4), rc.conf(5),
The edsc device was derived from the disc(4) device and first appeared in
FreeBSD 6.3. This manpage was adapted from disc(4).
Since outgoing packets are just discarded by edsc, ARP requests stay
unreplied. Consequently, an IP packet cannot be sent via edsc until a
static arp(4) entry is created for its next hop using arp(8).
Initially an edsc interface has a zero link level address. It can be
changed with ifconfig(8) lladdr if needed.
BSD March 25, 2007 BSD