MGX(4) OpenBSD Programmer's Manual (SPARC64) MGX(4)NAMEmgx - SMS MGX and MGXPlus accelerated 8/24-bit color frame buffers
mgx* at sbus?
wsdisplay* at mgx?
The Southland Media Systems (now Quantum 3D) MGX and MGXPlus are SBus
color frame buffers, with graphics acceleration capabilities.
The mgx driver interfaces the frame buffer with the wscons(4) console
framework. It does not provide direct device driver entry points but
makes its functions available via the internal wsdisplay(4) interface.
The MGX and MGXPlus frame buffers will adapt their resolution to the
monitor they are connected to. However, when not connected to a Sun
monitor, the device will default to the cgthree(4)-compatible 1152x900
resolution, with a refresh rate of 66Hz. A different resolution can be
forced using the set of DIP switches (sometimes covered by metal foil)
located near the SBus connector on the board itself.
The DIP switch settings are as follows:
Switches Resolution Refresh Details
1 2 3 4 Rate
OFF OFF OFF OFF 1024x768 77Hz
OFF ON OFF OFF 1280x1024 76Hz
ON ON OFF OFF 1152x900 66Hz
OFF OFF ON OFF 1152x900 76Hz
OFF ON ON OFF 1152x900 77Hz
ON ON ON OFF 1152x900 66Hz cgthree compatible
ON ON OFF ON 1152x900 66Hz cgsix compatible
OFF OFF ON ON 1280x1024 67Hz
ON ON ON ON probed probed factory default
All other combinations are unsupported and may damage the hardware.
SEE ALSOintro(4), sbus(4), wscons(4), wsdisplay(4)CAVEATS
This driver does not support mode switching at the moment, and drives the
card in PROM-compatible, 8 bit, mode only.
OpenBSD 4.9 April 15, 2008 OpenBSD 4.9