TVTWO(4) OpenBSD Programmer's Manual (SPARC64) TVTWO(4)NAMEtvtwo - accelerated 24-bit color frame buffer
tvtwo* at sbus?
wsdisplay* at tvtwo?
The Parallax XVideo and PowerVideo frame buffers, also known as `tvtwo',
are memory based color frame buffers, with graphics acceleration and
overlay capabilities, and hardware MPEG decoding.
The tvtwo driver interfaces the frame buffer to the wscons(4) console
framework. It does not provide direct device driver entry points but
makes its functions available via the internal wsdisplay(4) interface.
The XVideo and PowerVideo frame buffers will adapt their resolution and
refresh rate to the monitor they are connected to. However, when not
connected to a Sun monitor, the device will default to the
cgthree(4)-compatible 1152x900 resolution, with a refresh rate of 67Hz.
A different resolution can be forced using the rotary switch on the edge
of the board.
The available modes are as follows:
Rotary Resolution Refresh Rate
0 autodetect autodetect
1 1152x900 67Hz
2 1152x900 76Hz
3 1152x900 60Hz
4 1024x768 77Hz
5 640x480 60Hz
All other rotary positions will behave as position 0, except for
positions E and F. Position E enables the board built-in debugger on the
serial port, and should not be used by end-users. Position F selects the
video mode settings stored in the cards NVRAM. These settings cannot be
modified under OpenBSD.
SEE ALSOintro(4), sbus(4), wscons(4), wsdisplay(4)CAVEATS
This driver does not support any acceleration features at the moment.
OpenBSD 4.9 March 31, 2008 OpenBSD 4.9