AMI(4) OpenBSD Programmer's Manual AMI(4)NAMEami - American Megatrends Inc. MegaRAID PATA/SATA/SCSI RAID controller
ami* at pci?
scsibus* at ami?
The ami driver provides support for the MegaRAID family of RAID
- ACER MegaRAID ROMB-2E
- Apple Xserve G5 PCI Hardware RAID Card
- Dell CERC-PATA, PERC 2/DC, PERC 2/SC, PERC 3/DC, PERC 3/DCL,
PERC 3/QC, PERC 3/SC, PERC 4/DC, PERC 4/Di, PERC 4/SC, PERC
4e/DC, PERC 4e/Di, PERC 4e/SC, PERC 4e/Si
- FSC MegaRAID PCI Express ROMB
- Hewlett-Packard 438, 466, T
- Intel RAID Controller SRCS16, SRCS28X, SRCU41L, SRCU42E,
SRCU42X, SROMBU42E, SRCZCRX
- LSI Logic/AMI/Symbios MegaRAID, 523 SATA, i4 133 RAID, ATA 133-
2 Elite 1400, Elite 1600, Elite 1650, Enterprise 1200,
Enterprise 1300, Enterprise 1400, Enterprise 1500, Enterprise
1600, Express 100, Express 200, Express 300, Express 500,
Series 418, SCSI 320-0, SCSI 320-0X, SCSI 320-1, SCSI 320-1E,
SCSI 320-1LP, SCSI 320-2, SCSI 320-2E, SCSI 320-2X, SCSI 320-
4X, SATA 150-4, SATA 150-6, SATA 300-4X, SATA 300-8ELP, SATA
300-8X, SATA 300-8XLP
- NEC MegaRAID PCI Express ROMB
These controllers support RAID 0, RAID 1, RAID 5, JBOD, and
superpositions of those configurations.
Some cards support both I2O and a so-called `Mass Storage' mode of
operation. This driver only supports the `Mass Storage' mode; I2O mode
is supported by the iop(4) driver. However it is recommended to use
these cards in `Mass Storage' mode.
Although the controllers are actual RAID controllers, the driver makes
them look just like SCSI controllers. All RAID configuration is done
through the controllers' BIOSes.
The management interface is provided through the bio(4) device or one of
the daughter sd(4) devices as implemented in the bioctl(8) utility.
Logical disk status is exposed under the hw.sensors sysctl(8) and can be
monitored using sensorsd(8). For example:
$ sysctl hw.sensors.ami0
hw.sensors.ami0.drive0=online (sd0), OK
hw.sensors.ami0.drive1=degraded (sd1), WARNING
hw.sensors.ami0.drive2=failed (sd2), CRITICAL
SEE ALSObio(4), intro(4), pci(4), scsi(4), sd(4), bioctl(8), sensorsd(8),
The ami driver first appeared in OpenBSD 2.9.
The ami driver was written by Michael Shalayeff <firstname.lastname@example.org>.
Management functions were implemented by Marco Peereboom
OpenBSD 4.9 May 31, 2007 OpenBSD 4.9