DCONS(4) BSD Kernel Interfaces Manual DCONS(4)NAMEdcons — dumb console device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in your kernel configuration file:
and in loader.conf(5):
The dcons device is a simple console device which just reads from and
writes to an allocated buffer for input and output respectively. It is
of no use by itself and it is supposed that the buffer is accessed via a
bus like firewire(4) or kvm(3) for interaction.
The buffer consists of 4 channels. There are 2 ports, one for the con‐
sole TTY and another is GDB port, then each port has an input channel and
an output channel.
If you want to run getty(8) on dcons, insert the following line into
ttys(5) and send a HUP signal to init(8) using kill(1).
dcons "/usr/libexec/getty std.9600" vt100 on secure
Once the fwohci(4) device is initialized to allow physical access, the
buffer can be accessed from another host via a firewire(4) bus using the
dconschat(8) application. See dconschat(8) for more details.
If you want to use dcons(4) as a gdb(1) port, add the following line into
SEE ALSOdcons_crom(4), ddb(4), firewire(4), fwohci(4), gdb(4), ttys(5),
conscontrol(8), dconschat(8), fwcontrol(8)AUTHORS
Hidetoshi Shimokawa ⟨simokawa@FreeBSD.org⟩
This driver is currently under development.
BSD January 26, 2008 BSD